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本講義の概要
• CADツールQuartus Primeを⽤いた設計フロー
-HDL設計における使い⽅
-FPGAへの書き込みと実機上での実⾏

• 進め⽅
-加算器を練習として作成してもらいます
-HDL設計についてよく知っているのであれば練習は⾶ば

して、導⼊課題の7SEG LED駆動回路とカウンタの設計
をどんどん進めていって構いません
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2023年度以降の注意点
• 本資料は新演習室環境を想定して作成しています
-Ubuntu 22.04 LTS
-Quartus Prime 20.1 Standard Edition
-ModelSim Intel FPGA Starter Edition

• 各⾃のPC環境で作業する場合は適宜読み替えてく
ださい
-基本は⼤きく変わらないはずです
-環境違いによる詰まりどころが多いようなら，

Slack等で随時お知らせします
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FPGAとは︖
• Field Programmable Gate Array
-中⾝を改変可能なLSI

(PLD: Programmable Logic Device)
-ハードウェアそのものの

振る舞いを変えられる
-独⾃のデジタル回路を

⾃由に何回でも形成できる
-FPGA⼆⼤ベンダ︓

AMD(旧Xilinx），Altera(Intel)
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FPGAの⽤途
• ASICの設計・検証⽤LSIに活⽤
-ASICの機能を製造前に検証できる
-HWの完成前からSWの開発が始められる

• 最終製品に組み込むLSIに活⽤
-⺠⽣品での実⽤例は枚挙に暇がないほど多い
-出荷後のデータ書き換え機能を持たせることも
-最近の実⽤例

ü⾦融取引市場
üロボット
üデータセンター
ü機械学習
üオートモーティブ(ADAS)
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実験環境︓FPGAボード
• PowerMedusa MU500-RX/RK
-FPGA︓Altera社Cyclone IV

EP4CE30F23I7N (28,840LE)
-マイコン︓ルネサス社RX210
-クロック︓20MHz発振器
-⼊出⼒ユーザインタフェース

üプッシュSW x20, ロータリSW x2, 
8bit DIP SW x2, クロックSW x1

ü 7SEG LED x8, LED x8, ブザー x1
-拡張ボード MU500-7SEG

ü 7SEG LED x64, LED x64
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CADツール
• Computer-Aided Design: 
論理回路を設計，合成するツール
-環境設定，回路の設計と記述，回路合成，

ピンアサイン，シミュレーション，
プログラミング（FPGAへの書き込み）までを⾏う
-EDA(Electronic Design Automation)ツールとも呼ばれる
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実験環境︓CADツール（実験2と同じ）

• Intel Quartus Prime 20.1を⽤いる
-最新版ではない︕
-Google先⽣に聞く時にはバージョン番号に注意︕

ü公式マニュアルやドキュメントも別バージョンはアテにしない

• 各⾃のPCにもインストール可能
-機能制限有りの Lite Edition なら無償利⽤可能

üシミュレータはModelSim-Intel FPGA Starter Editionを⼊れる
p Starter無しIntel FPGA Editionは有償ライセンスが必要

ü次ページの補⾜も参照
-Windows/Linuxのみ（macOSは不可）
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補⾜︓Quartus Primeのインストール

• 各⾃PCへのQuartus Primeの導⼊
- 機能制限有りの Lite Edition なら無償利⽤可能です
- シミュレータ ModelSim-Intel Starter Edition は無償利⽤可能です

ü Starter無しの ModelSim-Intel Editionは有償ライセンスが必要
• エディションの違いについて
- Standard Editionだと30⽇間限定になります
- Pro Editionは使⽤できません (ボード搭載のCyclone VIが未対応)

• 合成性能や最適化結果がエディションで異なってくる可能性があります
- レポート記載の際には使⽤した Edition を明記してください

9



補⾜︓Quartus Primeのインストール
• Quartus Prime 20.1 Lite Editionのインストール⽅法
- Quartus Primeのダウンロードサイト

https://www.intel.co.jp/content/www/jp/ja/products/details/fpg
a/development-tools/quartus-prime/resource.html
ü “Legal Disclaimer” で最新版じゃなくて良いの︖の警告が

出ることがあるが，無視して “I Agree” すればよい
ü「⼀式ファイル」の場合は 5.9GB (Linux版 6.4GB)
ü「個別ファイル」の場合は下記を同場所にダウンロード

p Quartus Prime (includes Nios II EDS)
p ModelSim-Intel FPGA Edition (includes Starter Edition)
p Cyclone IV device support
計 3.2GB (Linux版 3.7GB)

- (次ページに続く)
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補⾜︓Quartus Primeのインストール
• Quartus Primeのダウンロード

1. QuartusPrimeのダウンロードページにアクセス。
2. Versionから”20.1”を選択
3. 「Multiple Download」タブから⼀式ファイルをダウンロード。または

「Individual Files」タブから個別ファイル（前ページ参照）をダウンロード。
• 必要なソフトウェアのインストール
- Quartusが動作するためにインストールする必要があるソフトウェアがある。以

下にアクセスして、右上の”Download”からPDFドキュメントを取得。
ü https://www.intel.com/content/www/us/en/docs/programma

ble/683472/20-1/introduction.html
- PDFドキュメントの”2.3 Software Requirements”に記載のパッケージをイン

ストールする
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補⾜︓Quartus Primeのインストール
• Quartus Prime 20.1 Lite Editionのインストール⽅法
- 「個別ファイル」の場合は，３ファイルを同位置に配置してください
- インストーラを起動し，適宜チェックを⼊れて実⾏してください

ü Installation directory はデフォルトで良いでしょう
(本資料等での説明はデフォルト位置を想定しています)

ü Select Components では，下記のチェックが必須です
p Quartus Prime (includes Nios II EDS)
p Devices > Cyclone IV
p ModelSim - Intel FPGA Starter Edition

Windowsの場合は，Quartus本体のインストール終了後に表⽰される
USB Blaster II device driverもインストールしてください

ü FPGAボードのUSBケーブルがうまく認識しない場合は，
こちらのページを参考にしてください．
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Quartusの起動
• ターミナル上で
$ /opt/intelFPGA/20.1/quartus/bin/quartus &
- 最後に&を⼊れるとバックグラウンドプロセスとして実⾏

ü https://ja.wikipedia.org/wiki/バックグラウンドプロセス
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PATHを通す⽅法
• 環境変数（$PATH）の記述を変更し，コマンドの検索
パスを追加する

• ターミナル上で
$ export PATH=“$PATH:/opt/intelFPGA/20.1/quartus/bin”

• こうすると，単にquartusと打つだけで起動できるよ
うになる

• ~/.bashrcに上のコマンドを書いておくと，シェル
（Bash）を起動する度に実⾏されるので，毎回設定す
る必要がなくなる
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設定の確認
• ライセンス認証
-初回起動時，If you have a valid license file, specify 

the location of your license fileにチェックしてOKを
クリック
- “License file: “ に ”27003@is-fpg-10” を⼊⼒するか
“LM_LICENSE_FILE variable:” にチェックして⼊⼒
-起動後，Tools -> License Setup..からも設定可能

• Webブラウザの設定
-Tools -> Options... の Internet Connectivity で，
“Web browser:” に好みのブラウザへのパスを設定
-何も好みがなければ ”/export/share/bin/firefox”

üエラー調査時に便利です
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• Quartusからmodelsim-aseを呼び出すための
設定をする
- Tools -> Options... -> EDA Tool Options:

ModelSim-Altera: /opt/intelFPGA/20.1/modelsim_ase/linuxaloem
ü ʻsʼ が抜けていることがあるので注意
üいったん空⽩にしてもよい

設定の確認
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ツール利⽤と設計の流れ
a. 新規プロジェクトの作成と環境設定
b. HDLコードの作成
c. コンパイル
d. タイミング制約の設定と検証
e. シミュレーションによる動作確認
f. トップレベル回路への⼊出⼒ピンの割当て
g. FPGAへの回路の書き込み

4ビット加算器をお題として設計フローを説明します
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練習は組合せ回
路なので無し



練習︓4bit加算機の設計



a. 新規プロジェクトの作成と設定（1/4）

• File -> New Project Wizard...

• Introduction “Next”
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• Directory, Name, Top-Level Entity

a. 新規プロジェクトの作成と設定（2/4）
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作業ディレクトリ︓
ホームディレクトリそのものを指定せず，
必ず専⽤のディレクトリを作ること．そう
しないとツールが固まったり落ちたりする
原因になる．
また，プロジェクト毎にディレクトリを
作ったほうがよい（名前は⾃由）

プロジェクト名

トップレベルの回路名︓
なにも気にしなければプロジェクト名と
同⼀（⾃動⼊⼒される）

作業ディレクトリが存在しない
場合は⾃動作成してくれる

数字から始まる、
または-(ハイフン)を含む
プロジェクト名や回路名は

随所でエラーが出るので避ける。



a. 新規プロジェクトの作成と設定（3/4）

• Project Type︓Empty projectを選択
• Add Files︓作成済みの回路をプロジェクトに追加する
- 今回はまだ何も無いので空⽩のまま”Next”

• Family & Device Settings
- Family:

”Cyclone IV E”
- Available devices: 

”EP4CE30F23I7”
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選択が⾯倒な場合は
フィルタ検索も可能

Available devices:から
EP4CE30F23I7を選択



a. 新規プロジェクトの作成と設定（4/4）

• EDA Tool Settings
- 外部の設計ツールを使⽤／
変更する場合に指定する
- “Simulation”にて使⽤する
HDLを指定する

• Summary
- 設定を確認して“Finish”
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実験2では…
• ブロック図によって加算器を設計した
-これだけでも⼿間がかかった

• 実験３ではハードウェア記述⾔語を⽤いること
で⾶躍的に⽣産性が⾼まる
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b. HDLコードの作成（1/3）
• HDLエディタを使⽤する
- File -> New -> Verilog HDL File または

File -> New -> VHDL File
ü ⾃分の使いたいHDLに合わせて選択する

- 実験3ではハードウェア記述⾔語による設計を
存分に楽しんでください
ü 回路図との組合せもOKです
ü トップレベルは回路図，部品はHDLとすると

全体の⾒通しが良くなります
• まずは(泣く前に)HDLファイルを保存
- File -> Save As...
- “adder4.v”

ü VHDLの場合は ”adder4.vhd”
• Tasks窓のFlow:を “Compilation”にする
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数字から始まる
ファイル名は避ける

本実験はVerilog-HDL前提
他の⾔語だと教員・TAもわからない可能性⼤



b. HDLコードの作成（2/3）
• (初期)ウインドウの構成
- 使いやすいようにレイアウトやサイズ等を適宜調整してよい

View -> Utility Windows など
- エディタ機能は貧弱なので，お好みのエディタを使⽤してもよい

(外部ツールとのファイル同期は⾃⼰責任で)
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エディタ画⾯

エディタ操作アイコン

ツール操作アイコン

メッセージウインドウ
処理メッセージや
エラー報告など

ファイルの⼀覧や
呼び出し関係

タスク(コンパイル等)の
進⾏状況の表⽰や
レポートの選択

Flow: “Compilation”とする



b. HDLコードの作成（3/3）
• Verilog HDLの例
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• VHDLの例



c. コンパイル（1/4）
• FPGA内の論理ブロックの構成情報に変換する
- 回路図をレジスタ転送レベルに変換する
- 論理合成，テクノロジマッピング，配置配線を⾏う

ü RTLで記述された回路をFPGA上の論理ブロックに割り付け，
論理ブロックの配置や配線を⾏う

- ビットストリームを⽣成する
ü 配置／配線の情報をバイナリ記述の構成情報ファイルに変換する

• コンパイル⼿順
- Processing -> Start Compilation または
ツール操作アイコンのStart Compilation または Ctrl+L
ü Start Analysis & Synthesis で⼊⼒チェックのみも可能
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c. コンパイル（2/4）
• Tasks窓の“Compilation”がall green✓になったら正常にコンパイル成功
- ⻩字︖はそのフローで再コンパイルが必要なことを表す
- ⾚字×はそのフローでエラーが発⽣していることを表す

• 正常終了しなかったら，下部のメッセージウインドウ または
 “Compilation Report -> Flow Messages” などを確認し，
 メッセージをもとにデバッグを⾏う
- 右クリック Help でメッセージのWeb検索可能
- Critical Waning / Warning も要チェック

ü CADツールでは警告がシビアに出⼒されがちだが，無視する場合も警告の
意味を理解しておくこと（設計ミスに気づくことも多い）
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c. コンパイル（3/4）
• Compilation Report で合成結果を確認する
- Processing -> Compilation Report または Ctrl+R
- 各項⽬の詳細は各⾃で調査すること
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c. コンパイル（4/4）
• 回路サイズ︓Fitter -> Summary
- FPGA上の各ブロックの使⽤量
- 100％を超える項⽬があるとFPGAデバイスに収まらない

• 動作速度と遅延︓Timing Analyzer
- SDCでset_max_delay， set_min_delayを設定すればそれぞれ

の⼊⼒端⼦から出⼒端⼦への伝搬遅延時間（単位はns）を表⽰で
きる（FAQ参照）
- 順序回路の設計で⼊⼒クロックを指定すれば，動作周波数なども
表⽰できるようになる
- ⾚字の項⽬がある場合はタイミング制約を満たしていない

üUnconstrained Pathsは set_max_delay, set_min_delayを
適切に設定すれば消える
順序回路設計では特に気にする必要がある
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d. タイミング制約の設定(参考)
• 練習の加算器は組み合わせ回路なので設定の必要はないが、クロッ

クを使⽤する順序回路では必ず設定する。
• クロックの指定やタイミング制約（レジスタ⼊⼒へのセットアップ
時間やホールド時間，伝搬遅延など）の設定を⾏う
- 基本的なクロックの指定のみ解説，詳細は各⾃で調査すること．

• Timing Analyzerを使⽤する
- Tools -> Timing Analyzer または，
ツール操作アイコンの “Timing Analyzer”
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d. タイミング制約の設定(参考)
• Timing Analyzer
- Tasks窓の “Netlist Setup -> Create Timing Netlist” を実⾏
- Tasks窓の “Netlist Setup -> Read SDC File” を実⾏
- Constraints -> Create Clock... からクロックを設定
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d. タイミング制約の設定(参考)
• Timing Analyzer
- Constraints -> Create Clock... からクロックを設定

ü Clock name: クロック名の定義 未記⼊でも可（例︓clock）
ü Period: クロック周期の設定
ü Waveform edges: ⽴ち上がり／⽴ち下がり時間の設定
ü Targets: 設計回路上のクロックを選択

p “List”から表⽰して”>”で選択
ü SDC commandに⽣成される

制約が表⽰される
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d. タイミング制約の設定(参考)
• Timing Analyzer
- Reports/ 以下でタイミングに関する種々のレポートが
報告されるようになる
ü 満⾜していないものがあれば制約の追加などで対処する
ü Compilation Report からも確認できるようになる
ü Fmax Summary: 動作可能な最⼤周波数（与える制約によって変わる）
ü Clocks: 現在設定値での設計回路のクロック周波数

- Tasks窓の “Write SDC File...” で制約ファイルを保存
ü <module>.sdc とするとプロジェクトに⾃動認識される

（.outを取ったほうがよい）
ü 慣れてきたらテキストベースで

制約ファイルを作成して編集してもよい
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e. シミュレーション（1/12）
• まずはテストベンチファイルを作成する
- テストベンチファイルとは，設計した回路が期待通りの動作をする
か確認するためのファイルのこと．

- ハードウェア記述⾔語Verilog HDLで記述する（実験3では⽂法の理解も
すること）

• 回路に任意の⼊⼒を与え，シミュレータModelSimで出
⼒を観測する
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e. シミュレーション（2/12）
• テストベンチファイルを作成する⼿順
- Processing -> Start -> Start Test Bench Template Writer
- ./simulation/modelsim/*.vt が作成される

• *.vt を編集 もしくは コピーして新しいファイルを作る
ü .vにするとエディタによってはverilogモードが使える

ü 時間単位を変更する
`timescale 1 ns / 1ps
p 1タイムステップが1ns、丸め精度（最⼩単位）が1psという意味

ü 以下の記述の直下に初期設定を記述する
// code that executes only once
// insert code here --> begin

ü 以下の記述の直下に所望の値（波形）を記述する
// code that executes for every event on sensitivity list
// insert code here --> begin
p eachvec信号は使わないので@eachvec;はコメントアウトか削除する

• 慣れてきたらTemplate Writerを使わなくても良い
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e. シミュレーション（3/12）
• テストベンチファイルの記法例
- 代⼊︓

A <= 0;
B <= B + 1;
Cin <= ~Cin; //反転
As <= 4ʼb10_01; // 4ビッ
トの2進数（binary）
ü (遅延が無ければ)並列に
代⼊される
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- 遅延︓
#1000
- 繰り返し︓

always begin
#100
clock <= ~clock;

end
ü クロック波形の⽣成に便利
ü initial begin - end や

always begin - end の外側，
module - endmodule の
内側に記⼊すること

ü alwaysブロック同⼠は
並列に実⾏される

ü eachvecは未使⽤のため
@eachvec;があると繰り返
されない

Verilog-HDLで書かれています。
何も指定しないと数字は⼗進数となります。



e. シミュレーション（4/12）
• テストベンチファイルの記述例
- 時間単位も変更済み
`timescale 1 ns / 1ps
ü 1タイムステップが1ns、丸め精

度（最⼩単位）が1ps
- この例は安直な真理値表の網
羅なので，⼯夫してみてくだ
さい
- 単位や遅延はよく考える

ü あまりに⼩さいと︖︖
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e. シミュレーション（5/12）
• Quartusからmodelsim-aseを呼び出すための設定をする
- Assignment -> Settings -> EDA Tool Settings -> Simulation

ü Tool name: ModelSim-Altera
ü Format for output netlist: 

Verilog HDL
（VHDLでの設計時はVHDL）

ü NativeLink settings: 
Compile test bench

ü Test Benches... をクリック

39
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e. シミュレーション（6/12）
- Test Benches

ü New... をクリック
- New Test Bench Settings

ü Test bench name: 任意の名前
ü Top level module in test bench: を
実際のテストベンチモジュール名にする
（Template writerを使った場合，*_vlg_tst
になっている）

ü Test bench and simulation files: 
simulation/modelsim/*.vt
(...から前ページで作成したファイルを選択)

ü Add をクリック
- Test Benchesに戻ってOK, Applyをクリック
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e. シミュレーション（7/12）
• テストベンチファイルの記述例
- 時間単位も変更済み
`timescale 1 ns / 1ps
- 単位や遅延はよく考える

ü あまりに⼩さいと︖︖
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@eachvec;は
コメントアウト



e. シミュレーション（8/12）
• 設計を再コンパイルする（タスク窓が︖になっているはず）

• シミュレータを起動する
- Tools -> Run Simulation Tool -> Gate Level Simulation...
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e. シミュレーション（9/12）
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Library
ウインドウ

時間単位の指定 Run等Restart

Waveウインドウ
Zoom変更可

Objectsウインドウ
観測したい信号を
Waveにドラッグ

Transcript
ウインドウ いろいろ

触ってみましょう



e. シミュレーション（10/12）
• 波形が表⽰されない場合
- テストベンチファイルを念のため再コンパイルしよう

ü “Library” ウインドウの gate_work -> <module>_vlg_tst を
右クリックして “Recompile”

- Transcriptionウィンドウに# Error loading design”が出て
いるか確認
ü 再コンパイルしても出ている場合，テストベンチファイルにミスがあ

るか，ファイルの指定が間違っているなどの可能性がある
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e. シミュレーション（11/12）
• 波形が表⽰されない場合（その2）
- Simulate -> Start Simulation...
- Design タブの ”Design Unit(s)” にて

gate_work.<module>_vlg_tst を選択
- Libraries タブの “Search Libraries” にて Add... して

必要なライブラリを追加する (”cycloneive_ver“のみ選択でよい)
ü ”altera_ver”, ”gate”, “gate_work” が⾃動的に⼊っていることが

あるが，どちらでもよい
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e. シミュレーション（12/12）
• その他の操作
- “Objects” ウインドウから観測したい信号線を

”Wave” ウインドウにドラッグする
- “Run Length” を所望の⼤きさにする（例︓100ns）

ü ⼤きすぎるとシミュレーション時間が掛かる
- “Run” や “Run - All” などをクリックする

ü “Transcript” ウインドウで直接⼊⼒も可能
(慣れてきたらこっちのほうが早いかも)

- 波形の表⽰は右クリックまたはキー⼊⼒で
Zoom In/Out/Fullなどが変更可能
- 波形はテストベンチで指定済みだが，直接指定も可能

ü 信号線の右クリックで”Force...”など
- テストベンチを変更した場合は，

“Library” ウインドウからRecompileして “Restart”

46



f. ⼊出⼒ピンの割当て（1/3）
• 回路の信号線をFPGAの⼊出⼒ピンに割り当てる
- 割当ての指定に応じて，ボード上のスイッチから⼊⼒を与えたり，

LEDに信号を出⼒したりできるようになる
- どのモジュールがどの⼊出⼒ピンに対応しているかは
ユーザーズマニュアルとピンアサイン表 を参照すること
ü ピンアサイン表まとめ が非常に便利

p https://panda.ecs.kyoto-u.ac.jp/access/content/group/2024-110-
9084-000/HWマニュアル/ピンアサイン表_rev.xlsx

• FPGAの⼊出⼒ピンと各種装置との対応は，
取扱説明書およびピンアサイン表を精読する
- 今回の例では，2つの⼊⼒値をディップSWのA,B，

キャリーインをテンキーのプッシュSW SW4，
和とキャリーアウトをLEDとしている
- 上記ピン割当ては使い勝⼿に応じて⾃由に変えてみましょう
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f. ⼊出⼒ピンの割当て（2/3）
• Pin Plannerを起動する
- “Assignments” -> “Pin Planner” または Ctrl+Shift+N
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f. ⼊出⼒ピンの割当て（3/3）
• ⼊出⼒ピンを割り当てていく
- Node NameとLocationを対応づける
- ピンの名前が出てこない場合は設計を再コンパイルする
- 別のピン名が出る場合は，Top-levelになっているか確認する
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ピン名と⼊出⼒⽅向
⼀覧がおかしい場合は

コンパイル状況や
Top-levelを確認する

Location列でFPGAのピンを指定する
(“PIN_”を省略した)直接⼊⼒も可能

他の列は⾃動⼊⼒される

デバイス名を確認
違う場合は設定を⾒直す

この例ではどこに何が
割り当てられている??



f. ⼊出⼒ピンの割当て（3/3）
• 今回の割当て例
- ディップスイッチで⼊⼒を与える
- 結果をLEDで表⽰させる

• ピンアサイン表まとめ を見ながら
やってみよう
- https://panda.ecs.kyoto-

u.ac.jp/access/content/group/2024
-110-9084-000/HWマニュアル/ピン
アサイン表_rev.xlsx

ディップスイッチ

LED



g. FPGAへの回路の書き込み
• 合成した回路イメージをFPGAに書き込み，実機上で動作を検証する
- 実機で動作して初めて設計の完了︕
- Tasks窓が⻩字︖の場合は再コンパイル，
⾚字×の場合はエラーなのでHDLコード等をデバッグする
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g. FPGAへの回路の書き込み
• FPGA書き込みツールを起動する
- “Tools” -> “Programmer” または
Tasks窓の”Program Device (Open Programmer)”
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g. FPGAへの回路の書き込み
• FPGAボードをPCに接続
-電源に接続
-USBを接続
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g. FPGAへの回路の書き込み
• Programmerの設定を⾏う
- Hardware Setupをクリックして，

Currently selected hardware: を “USB-Blaster [X-X]” とする
üAvailable hardware itemsにUSB-Blasterが出てこない時は，

PCとUSB接続し直す．それでも出てこない場合はデバドラの
問題も考えられるのでTAまで．

- Modeを”JTAG”にする
- リストにファイルが表⽰されて

いない場合は，Add File... から
書き込むファイルを選択する
ü ./output_files/
<proj_name>.sof

- リスト上のProgram/Configureに
チェックを⼊れる
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数字は環境に
よって異なる



g. FPGAへの回路の書き込み
• Programmerの設定を⾏う
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USB-Blaster を
選択

JTAGになっている
ことを確認

正しいデバイスが出ていることを確認
無ければ”Auto Detect”かUSBを繋ぎ直す

.sofを追加する
チェックする書き込み対象の

FPGAイメージファイル



g. FPGAへの回路の書き込み
• FPGAに回路を書き込む
- Startをクリック
- Process: が緑の”100% (Success)”になったら書き込み完了
- FPGAボードが認識されているのに、書き込みがうまくいかない(Failed

になる)場合，以下のコマンドを実⾏（jtagdを再起動）してもう⼀度試
す
ü killall -9 jtagd
ü /opt/intelFPGA/20.1/quartus/bin/jtagconfig

p エラーが出ないことを確認
ü 詳細は https://isle3hw.kuis.kyoto-u.ac.jp/faq.html#programmer_failed を参照

• 実機上で動作を検証する
- 正しく所望の動作ができて

いれば完了︕
- ディップスイッチは負論理なので注意

ü ONで0になる
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TIPS
• うまくいかない場合はまずFAQを確認。
- 過去にあった様々な質問とそれに対する回答がまとめられています。

• 実機で思った通りに動かない
- まずはシミュレーションで論理的に正しく設計できているか，

きちんと確認しましょう
- シミュレーションが上⼿くいっていても実機で動かないことも

よくあります．多くはタイミング制約を満⾜できていないことに
起因します．FAQを参考にしてください．

• ⼊出⼒装置が思った通りに動かない
- もちろん設計が正しいかは当然として，⼊出⼒装置には
それぞれ正論理と負論理があります

- 7SEG LEDはセレクタ信号の設定も必要です
- 未割り当てのLED(ピン)が光るのは無視して構いません

ü きちんと考慮するのが綺麗ですが，，，
- 詳しくは要するに取扱説明書を精読してください
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TIPS
• 実機上で⾊々な情報を⼀度に出⼒したい
- 拡張ボードMU500-7SEGを使いましょう

ü使い⽅の詳細は取扱説明書を参照してください
- 拡張ボードを使いこなせば，プロセッサのPC現在値だったりを

実機上で確認できるようになってデバッグが⾮常に捗ります
• HDLの回路を回路図エディタから呼び出したい
- 対象ファイルを選択した上で “Files” -> “Create / Update” ->

“Create Symbol Files for Current File” を選択する
ü回路図エディタから部品インスタンスとして配置できる
ü逆もできます(回路図をHDLから下位モジュールとして呼び出し)

- プロセッサ設計では，全体のアーキテクチャとデータパスは
回路図エディタで設計し，各部品はHDLで設計するのも良いでしょう
ü全体の⾒通しがよくなります
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TIPS
• HDLからどんな回路が合成されるか知りたい
- “Tools” -> “Netlist Viewers” -> “RTL Viewer” で

合成回路をなんとなく可視化できます
- ⾃分のHDLがどのような回路に合成されるのか，HW設計とは

なんたるかを知るのに有⽤な機能です
ü今回の例題だとまったく⾯⽩くないですが，，，
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TIPS
• シミュレーション
- modelsim-aseの Transcript サブウィンドウに直接コマンドを

⼊⼒して実⾏できる．慣れてきたらメニューをクリックするより
早い．コマンドヒストリも使える．
- 実⾏履歴は “./simulation/modelsim/msim_transcript” に残る

ので，編集して別名で保存しておくとよい．
Transcriptから do (ファイル名) で実⾏できる．

• モジュールについて
- 回路全体ではなく⼀部だけを合成したりシミュレーションしたい

場合は，Project Navigator の該当ファイルを右クリックして
”Set as Top-Level Entity” を設定するとよい

• バージョン Quartus Prime 20.1 / ModelSim ASE 10.5b
- Google先⽣に聞く時はツールのバージョンに注意すること．
古い／新しいために通⽤しないTIPSや解決策がある．
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