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実験概要
• CADツールQuartus Primeの使⽤⽅法を習得し，
論理回路の設計⼿法を学ぶ．

• マイクロプロセッサの主要な構成要素である
ALUについて，複数の回路構成⽅式を検討し，
その性能や回路規模を⽐較する．

• 任意の順序回路を考案し，CADツールを⽤いて
設計する．
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スケジュール
• 2019/12/24︓講義・実習
-講義︓FPGAことはじめ
-実習︓Quartus Primeの使い⽅

加算器・カウンタの設計
ü講義資料はPandAを参照のこと

• 2020/01/07︓演習(1) ALUの設計
• 2020/01/21︓演習(2) 任意の順序回路の設計

• 2020/01/28 17:00︓レポート提出期限
-期限厳守︕
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講義内容
• FPGAことはじめ
-基礎知識と構成
-活⽤のメリットと⽤途
-CADツールと設計フロー

• 実習課題(1)︓加算回路の設計
-半加算器を⽤いた全加算器
-全加算器を⽤いた4ビット並列加算回路

• 実習課題(2)︓カウンタの設計
-フリップフロップの利⽤
-クロックとタイミング制約の設定
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FPGAことはじめ

-基礎知識と構成
-活⽤のメリットと⽤途
-CADツールと設計フロー



「決められたことをすぐにやる」
• 特定⽤途のみに特化した

専⽤のアーキテクチャ構成
• 必要なだけのデータ幅と演算

計算資源
「⾔われたことはなんでもやる」

• すべてのケースをカバーする
汎⽤データパス

• 固定されたデータ幅と演算プロセッサ
＆

ソフトウェア

ASIC
(専⽤回路)

ハードウェア
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プロセッサ vs. ASIC

設計容易性・柔軟性

開発製造コスト

省電⼒性

性能・並列性プロセッサ
＆

ソフトウェア

ASIC
(専⽤回路)

ハードウェア

FPGA
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FPGAとは︖
• Field Programmable Gate Array
-中⾝を改変可能なLSI

(PLD: Programmable Logic Device)
-ハードウェアそのものの

振る舞いを変えられる
-独⾃のデジタル回路を

⾃由に何回でも形成できる
-FPGA⼆⼤ベンダ︓

Xilinx・Altera (powered by Intel)
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論理ブロックの論理表現
• プロダクトターム⽅式
-代表例︓PLA (Programmable Logic Array)

-ANDとORアレイのメッシュ接続による最⼩積和形表現
• ルックアップ・テーブル⽅式
-フリップフロップと組み合わせて論理ブロックを実現

9

���

��

�� ��

���

���

��

��� ��

��

�� ��

��

��

�� ��

�� ���� ������ ��

�� �� ��

��� ���

�� ��

�� ��

�� ��

LUT
IN OUT

0000 1
0001 0
0010 0

… …
1110 1
1111 0

D-FF

D Q



FPGAの強み
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FPGA

Memory

Func Func

Func FuncFunc

Func FuncFunc

FuncFunc

CPU

MemoryFunc
Unit Reg

• 1つのLSIで様々なシステムを設計できる
- プロセッサ処理より⾼性能かつ省電⼒を実現する
- ASICよりも製造コストを抑えられる

• データストリーム処理の実現が可能になる
- ノイマン・ボトルネックの解消に︕



FPGAの⽤途
• ASICの設計・検証⽤LSIに活⽤
- ASICの機能を製造前に検証できる
- HWの完成前からSWの開発が始められる

• 最終製品に組み込むLSIに活⽤
-⺠⽣品での実⽤例はすでにキリが無いほど多い
-出荷後のデータ書き換え機能を持たせることも
-最近の実⽤例

ü ⾦融市場取引
ü ロボット
ü データセンター
ü 機械学習
ü オートモーティブ（ADAS）
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⾦融市場取引
• 株式相場の値動きを解析して⾼速に売買取引
-⾼頻度取引（HFT）の⾃動売買では超⾼速応答が必須

12出典︓井上, FPGAによる⾦融業務アクセラレーション­複合イベント処理を題材に­, 情報処理, 2012.
W. Wang, “Black-Scholes in hardware,” Overload Journal, 2012.



ロボット
• Phenox: FPGA搭載ドローン（Xilinx Zynq XC7Z010）
-FPGA部分は主に信号処理を担っている

13出典︓ http://phenoxlab.com

http://phenoxlab.com/


データセンター
• Microsoft Catapult

14出典︓A. Putnam, et al. A Reconfigurable Fabric for Accelerating Large-Scale Datacenter Services, ISCA, 2014.
A. Putnam, Large-Scale Reconfigurable Computing in a Microsoft Datacenter, HotChips26, 2014.



機械学習
• CNN/DNNのアクセラレータ
-パイプラインをニューロン・シナプスの値が流れる

15
出典︓K. Ovtcharov, et al. Toward Accelerating Deep Learning at Scale Using Specialized Hardware in the Datacenter, 

HotChips27, 2015.
C. Zhang, et al. Optimizing FPGA-based Accelerator Design for Deep Convolutional Neural Networks, FPGA 2014.



オートモーティブ
• ADASの実現⽀援
- Xilinx︓ADAS向け処理チップとして，

2016年内で累計23社計85⾞種にFPGAが搭載予定
- Altera︓Audi社が⾃動運転システムzFASにCyclone Vを採⽤

16出典︓https://japan.xilinx.com/applications/automotive.html
http://techon.nikkeibp.co.jp/atcl/news/16/062702771/

https://japan.xilinx.com/applications/automotive.html
http://techon.nikkeibp.co.jp/atcl/news/16/062702771/


最近の技術トレンド
• 回路規模・集積度の増⼤
-1つのLSIで⾼機能・多様なシステムを実現可能
-マルチダイ化，3次元積層など今後もさらに増⼤

• プロセッサとFPGAの密結合化
-組込み︓ハードマクロのArmプロセッサと混載（Zynq等）
-汎⽤・サーバ︓Xeon等との統合（混載 or PCIe）
-より⾼品質なHW/SW協調システムが実現可能になる

• ⾼位合成／協調設計
-抽象度の⾼い動作記述からRTLを⽣成する技術
-汎⽤プログラミング⾔語によって振る舞いを定義

ü多くのツールはC/C++またはその拡張⾔語
17



FPGAの設計フロー
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設計記述

論理シミュレーション

論理合成

テクノロジ・マッピング

配置配線

ビットストリーム⽣成

ブロック図やIP(Intellectual Property)
コア，ハードウェア記述⾔語（HDL，
実験3にて）等による論理回路の設計

ポストレイアウト
シミュレーション

設計記述の論理動作が正しいかを検証



FPGAの設計フロー
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設計記述

論理シミュレーション

論理合成

テクノロジ・マッピング

配置配線

ビットストリーム⽣成

ポストレイアウト
シミュレーション

ゲートのネット
リストを合成 LUTのネット

リストを合成
LUT

LUT

LBへのLUTの
割当てと接続を決定

素⼦や配線の遅延も考慮した
タイミングが正しいかの検証



CADツール
• Computer-Aided Design:
論理回路を設計・合成するツール
-環境設定，回路の設計と記述，回路合成，

ピンアサイン，シミュレーション，
プログラミング（FPGAへの書き込み）までを⾏う
-EDA(Electronic Design Automation)ツールとも呼ばれる

20



レジスタ転送レベル
• RTL: Register-Transfer Level
• デジタル回路を記述する⼿法の⼀種で，
回路の動作を構成する表現
-データ転送︓レジスタ間のデジタル信号の流れ
-それに対する論理演算の組み合わせ

ü Timed設計︓「なに」を「いつ」「どのように」を表現

21
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実習課題(1)︓加算回路の設計

-半加算器を⽤いた全加算器
-全加算器を⽤いた4ビット並列加算回路



実習課題(1)
• 加算回路の設計を通して，Quartus Primeの
使⽤⽅法および論理回路の設計⽅法を学ぶ
A) 半加算器を⽤いた全加算器
B) 全加算器を⽤いた4ビット並列加算回路

• 進め⽅
-ハンズオン形式で⾏いますが，⾃⼒でできそうなら

どんどん実習課題・演習課題を進めていって構いません
-「実習課題で」詰まったら積極的にTAを捕まえましょう
-実習課題に関するレポートの作成・提出は不要です
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実験環境︓CADツール
• Intel Quartus Prime 17.1を⽤いる
-演習室PCには”Standard Edition”がインストール済み
-Google先⽣に聞く時にはバージョン番号に注意︕

ü公式マニュアル・ドキュメントも別バージョンはアテにしない

• 各⾃のPCにもインストール可能
-機能制限有りの Lite Edition なら無償利⽤可能

http://dl.altera.com/?edition=lite
üシミュレータはModelSim-Altera Starter Editionを⼊れる
ü TIPSページの補⾜も参照のこと

-Windows/Linuxのみ（Mac OS Xは不可）

24

http://dl.altera.com/%3Fedition=lite


Quartus Primeの起動
• ターミナル上で
$ quartus &

25



設定の確認
• ライセンス認証
-Tools -> License Setup... で，

“Not found” と⾔われていないことを確認
-そう⾔われている場合や，起動時にLicense Setup 

Requiredとか出てくる場合は，
“License file: “ に ”27000@is-fpg-00” を⼊⼒するか
“LM_LICENSE_FILE variable:” にチェック・⼊⼒

• Webブラウザの設定
-Tools -> Options... の Internet Connectivity で，

“Web browser:” に好みのブラウザへのパスを設定
-何も好みがなければ ”/export/share/bin/firefox”

üエラー調査時に便利です
26



• Quartusからmodelsim-aseを呼び出すための
設定をする
- Tools -> Options... -> EDA Tool Options:

ModelSim-Altera: 
/home/quartus/intelFPGA/17.1/modelsim_ase/linuxaloem
ü ʻsʼ が抜けていることがあるので注意
üいったん空⽩にしてもよい

設定の確認

27



ツール利⽤と設計の流れ
a. 新規プロジェクトの作成と環境設定
b. 論理回路の設計
c. 回路図の作成
d. コンパイル
e. シミュレーションによる動作確認
f. トップレベル回路への⼊出⼒ピンの割当て
g. FPGAへの回路の書き込み

実験2ではf.以降は⾏いません
（実機で動かしたい余裕がある気になる⽅はTAまで）
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A) 半加算器を⽤いた全加算器

-新規プロジェクトの作成と環境設定
-論理回路の設計
-回路図の作成とブロック化・流⽤
-コンパイル
-シミュレーションによる動作確認



a. 新規プロジェクトの作成と設定
• まずは半加算器を⽤いた1ビット全加算器を設計する
- File -> New Project Wizard...

• Introduction “Next”

30



• Directory, Name, Top-Level Entity [page 1 of 6]

a. 新規プロジェクトの作成と設定

31

作業ディレクトリ︓
ホームディレクトリそのものを指定せず，
必ず専⽤のディレクトリを作ること．そう
しないとツールが固まったり落ちたりする
原因になる．
また，プロジェクト毎にディレクトリを
作ったほうがよい（名前は⾃由）

プロジェクト名

トップレベルの回路名︓
なにも気にしなければプロジェクト名と
同⼀（⾃動⼊⼒される）

作業ディレクトリが存在しない
場合は⾃動作成してくれる
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a. 新規プロジェクトの作成と設定
• Project Type [page 2 of 6]
- プロジェクトの種類を選択する
- テンプレートからプロジェクトを作成することもできる
- 今回は”Empty project”を選択

• Add Files [page 3 of 6]
- 作成済みの回路をプロジェクトに追加する
- 今回はまだ何も無いので空⽩のまま”Next”
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a. 新規プロジェクトの作成と設定
• Family & Device Settings [page 4 of 6]
- Family: 

”Cyclone IV E”
- Available devices: 

”EP4CE30F23I7”

選択が⾯倒な場合は
フィルタ検索も可能



a. 新規プロジェクトの作成と設定
• EDA Tool Settings [page 5 of 6]
- 外部の設計ツールを使⽤／変更する場合に指定する
- 学⽣実験では特に使⽤／変更しないのでこのまま”Next”

• Summary [page 6 of 6]
- 設定を確認して“Finish”
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b. 論理回路の設計
• 設計したい論理回路を考える
-外部仕様︓⼊⼒・出⼒，機能
-内部仕様︓回路構成

ü真理値表，カルノー図，状態遷移図，，， → 論理式表現
まずは設計してからツールを使い出すこと︕

• 半加算器の外部仕様
-⼊⼒︓1ビットの加算データA,B
-出⼒︓1ビットの和Sum，

1ビットの桁上げCarry
論理式表現は分かりますよね，，，

35

A B Carry Sum
0 0 0 0
0 1 0 1
1 0 0 1
1 1 1 0



b. 論理回路の設計
• 全加算器の外部仕様
-⼊⼒︓1ビットの加算データA,B，

1ビットの下位からの桁上げCin
-出⼒︓1ビットの和Sum，

1ビットの桁上げCout
-半加算器を利⽤すること

論理式表現は分かりますよね，，，

36

A B Cin Cout Sum
0 0 0 0 0
0 0 1 0 1
0 1 0 0 1
0 1 1 1 0
1 0 0 0 1
1 0 1 1 0
1 1 0 1 0
1 1 1 1 1



c. 回路図の作成
• 回路図エディタを使⽤する
- File -> New -> Block Diagram/Schematic File
- 実験2ではブロック図のみを⼊⼒とした設計とする

ハードウェア記述⾔語による設計は認めません︕
ü 今年度は素⼦を組み合わせて回路を構成することを

楽しんでください

• まずは(泣く前に) 回路図ファイルを保存
- File -> Save As...
- “halfadder.bdf”

• Tasks窓のFlow:を
“Compilation”にする

37



c. 回路図の作成
• (初期)ウインドウの構成
- 使いやすいようにレイアウトやサイズ等を適宜調整してよい

View -> Utility Windows など

38

回路図⾯

回路図操作アイコン

ツール操作アイコン

メッセージウインドウ
処理メッセージや
エラー報告など

回路図等のファイルの
⼀覧や呼び出し関係

タスク(コンパイル等)の
進⾏状況の表⽰や
レポートの選択

Flow: “Comppilation”とする



c. 回路図の作成
• 論理素⼦／回路ブロックの配置
- 回路図⾯上のダブルクリック，または，

回路図操作アイコンのSymbol Tool
- 基本的に”Primitives”の中の素⼦だけを使いましょう

ü Megafunction等を使いたい場合は妥当な説明を⽰してください

39

選択が⾯倒な場合は
フィルタ検索も可能



c. 回路図の作成
• 論理素⼦／回路ブロックの配置
- 必要な論理素⼦を配置していく
- 左上は素⼦名
- 左下の“instX”の部分はインスタンス名

ü 名前を変更することができる（⾃動的に適当な番号を振ってくれる）
ü 要所要所に分かりやすい名前を付けておいたほうがデバッグが楽

40

インスタンス名



c. 回路図の作成
• ⼊出⼒端⼦の配置
- Symbolウインドウの Primitives -> pin ，

または，回路図操作アイコンのPin Tool
- 必要な⼊出⼒端⼦を配置していく
- 左右の“pin_nameX”の部分はインスタンス名

ü こちらは必ず意味のある名前を付けるべき
ü ダブルクリックまたは右クリック “Properties” 

でも名前を変更できる
- ⼊⼒端⼦右下のVCCは初期値（GNDに変更可）

41



c. 回路図の作成
• 論理素⼦・端⼦などの間の配線
- 回路図操作アイコンのOrthogonal Node Tool

ü ここでは1bit幅の配線のみでOK
ü 1回の配線につき1回までしか曲げられない

もっと曲げたい場合は2回以上に分けて配線する
- 必要に応じて配線にも名前を付けてよい

ü 右クリック “Properties” 
ü 必ずしも端⼦名と⼀致させる必要は無い

42



c. 回路図の作成
• 部品化（シンボル化）
- 他の回路図ファイルから参照可能なシンボルファイルを⽣成する

ü プログラミングにおけるライブラリ化に相当するといってよい
ü 回路図ファイルを分割・階層化できる

- File -> Create / Update -> 
Create Symbol Files for Current Files

- “Symbol File (*.bsf)”として保存する
ü 理由が無ければ回路名と同じにする
ü “Canʻt open read-only file 

<module>.bsf”と⾔われる場合は，
設計ディレクトリ（qpf や bdf が
あるところ）で，以下を実⾏する
$ touch <module>.bsf
$ chmod o+w <module>.bsf

43



c. 回路図の作成
• 他の部品（シンボル）を利⽤した回路図の作成
- 新しくブロック図ファイル（”fulladder.bdf”）を作成する
- Symbol Toolの”Project”以下に先ほど⽣成した”halfadder”が

追加されている
- 元の回路図を変更した場合は，.bsf を保存して，シンボルの

右クリック “Update Symbol or Block...” すると変更が反映される

44



c. 回路図の作成
• 全加算器”fulladder.bdf”の作成
- 今までの⼿順と同様

45



d. コンパイル
• FPGA内の論理ブロックの構成情報に変換する（Cのコンパイルに相当）

- 回路図をレジスタ転送レベルに変換する
- 論理合成・テクノロジマッピング・配置配線を⾏う

ü RTLで記述された回路をFPGA上の論理ブロックに割り付け，
論理ブロックの配置や配線を⾏う

- ビットストリームを⽣成する
ü 配置／配線の情報をバイナリ記述の構成情報ファイルに変換する

• コンパイル⼿順
- Processing -> Start Compilation または

ツール操作アイコンのStart Compilation または Ctrl+L
ü Start Analysis & Synthesis で⼊⼒チェックのみも可能

46



d. コンパイル
• メッセージウインドウに“Quartus Prime Full Compilation was 

successful”が表⽰されたら正常にコンパイル成功
- タスク窓が全て緑字✓になっているはず
- ⻩字︖はそのフローで再コンパイルが必要なことを表す
- ⾚字×はそのフローでエラーが発⽣していることを表す

• 正常終了しなかったら，下部のメッセージウインドウ または
“Compilation Report -> Flow Messages” などを確認し，
メッセージをもとにデバッグを⾏う
- メッセージの意味は，右クリック -> Help でWeb検索可能
- Critical Waning / Warning も要チェック

ü CADツールでは警告がシビアに出⼒されがちだが，警告の意味を
理解した上で無視すること（設計ミスとかに気づくことも多い）
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d. コンパイル
• Compilation Report で合成結果を確認する
- Processing -> Compilation Report または Ctrl+R
- 各項⽬の詳細は各⾃で調査すること
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d. コンパイル
• 回路サイズ︓Fitter -> Summary
- FPGA上の各ブロックの使⽤量
- 100％を超える項⽬があると該当のFPGAデバイスに収まらない

• 動作速度・遅延︓TimeQuest Timing Analyzer
- Datasheet Reportにそれぞれの⼊⼒端⼦から出⼒端⼦への

伝搬遅延時間（単位はns）が表⽰される
- 順序回路では，⼊⼒クロックを指定すれば，動作周波数なども

表⽰できるようになる
ü今は組合せ回路なので詳細は後ほど

- ⾚字の項⽬がある場合はタイミング制約を満たしていない
ü Unconstrained Pathsは実験2では無視してよい

(FPGAデバイスとの⼊出⼒ピンを接続しないといけない，実験3にて)
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e. シミュレーション
• 設計した論理回路が正しく動作するかを波形エディタで確認する
- ModelSim-Altera Starter Edition (modelsim-ase) を⽤いる

ü modelsim-ae もあるので注意（ライセンスが切れていて動かない）
• まずはQuartusからmodelsim-aseを呼び出すための設定をする
- Assignment -> Settings -> EDA Tool Settings -> Simulation

ü Tool name: ModelSim-Altera
ü Format for output 

netlist: Verilog HDL
p VHDLでも良いが，

後で必要な設定が
少し増えるので
サポート外

ü NativeLink settings: 
Compile test bench

ü Test Benches... を選択
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e. シミュレーション
• まずはQuartusからmodelsim-aseを呼び出すための設定をする
- Test Benches

ü New... を選択
- New Test Bench Settings

ü Test bench name: 名前を付けて作成
ü Top level module in test bench: を

実際のテストベンチモジュール名 (Template
Writer を使うなら <module>_vlg_tst) に
しておくと，ModelSim起動の⼀発⽬で
Error loading design が出なくなる

ü Test bench and simulation files: 
simulation/modelsim/<module>_test1.vt
p ターミナルから空ファイルを作成しておく

ü Add を選択
- Test Benchesに戻ってOKを選択
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e. シミュレーション
• テストベンチファイルを作成する
- Processing -> Start -> Start Test Bench Template Writer
- ./simulation/modelsim/<module>.vt が作成される
- ./simulation/modelsim/<module>_test1.vt などにコピー

$ cp ./simulation/modelsim/fulladder.vt ¥
./simulation/modelsim/fulladder_test1.vt ¥

- 所望の⼊⼒波形が得られるように <module>_test1.vt を編集
ü 時間単位を変更する（デフォルトは ps なので速すぎる）

`timescale 1 ns / 1ps
ü 以下の記述の直下に初期設定を記述する

// code that executes only once
// insert code here --> begin

ü 以下の記述の直下に所望の値（波形）を記述する
// code that executes for every event on sensitivity list
// insert code here --> begin
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e. シミュレーション
• テストベンチファイルの記法例
- 代⼊︓

// 1ビット
A <= 0;
B <= B + 1;
// ビット演算
Cin <= ~Cin;
// 4ビットの2進数
As <= 4ʼb10_01;
// 4ビットの2進数
As <= 4ʼb10_01;
ü (遅延が無ければ)並列に

代⼊される

53

- 遅延︓
#1000
- 繰り返し︓

always begin
#100
clock <= ~clock;

end
ü クロック波形の⽣成に便利
ü initial begin - end や

always begin - end の外側，
module - endmodule の
内側に記⼊すること

ü alwaysブロック同⼠は
並列に実⾏される

ü @()で条件の記述も可能



e. シミュレーション
• テストベンチファイルの記述例
- 時間単位も変更済み

`timescale 1 ns / 1ps
- 安直な真理値表の網羅なので，

⼯夫してみてください
- 単位や遅延はよく考える

ü あまりに⼩さいと︖︖
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e. シミュレーション
• 設計を再コンパイルする（タスク窓が︖になっているはず）

• シミュレータを起動する
- Tools -> Run Simulation Tool -> Gate Level Simulation...
- Timing model: “Slow -7 1.2V 100 Model” で Run
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e. シミュレーション
• シミュレータを起動する
- 設計した回路は Library の gate_work 以下にある

ü work 内は gate_work へのリンク
• テストベンチファイルを念のため再コンパイル
- “Library” ウインドウの gate_work -> <module>_vlg_tst を

右クリックして “Recompile”
ü 起動直後は”# Error loading design”が出ることがあるが

再コンパイルで解消されるので気にしなくてよい
ü テストベンチを書き換える都度で再コンパイルが必要となる
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e. シミュレーション
• シミュレーションの開始
- Simulate -> Start Simulation...
- Design タブの ”Design Unit(s)” にて

gate_work.<module>_vlg_tst を選択
- Libraries タブの “Search Libraries” にて Add... して

必要なライブラリを追加する (”cycloneive_ver“のみ選択でよい)
ü ”altera_ver”, ”gate”, “gate_work” が⾃動的に⼊っていることが

あるが，どちらでもよい
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e. シミュレーション
• シミュレーションの実⾏
- “Objects” ウインドウから観測したい信号線を

”Wave” ウインドウにドラッグする
- “Run Length” を所望の⼤きさにする（例︓100ns）

ü ⼤きすぎるとシミュレーション時間が掛かる
- “Run” や “Run - All” などをクリックする

ü “Transcript” ウインドウで直接⼊⼒も可能
(慣れてきたらこっちのほうが早いかも)

- 波形の表⽰は右クリックまたはキー⼊⼒で
Zoom In/Out/Fullなどが変更可能
- 波形はテストベンチで指定済みだが，直接指定も可能

ü 信号線の右クリックで”Force...”など
- テストベンチを変更した場合は，

“Library” ウインドウからRecompileして “Restart”
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e. シミュレーション
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Libraryウインドウ

時間単位の指定 Run等Restart

Waveウインドウ
Zoom変更可

Objectsウインドウ
観測したい信号を
Waveにドラッグ

Transcript
ウインドウ いろいろ

触ってみましょう



B) 全加算器を⽤いた
4ビット並列加算回路

-他プロジェクトからの設計の流⽤
-バスの利⽤
-並列加算回路の構成



4ビット並列加算回路
• 全加算器を接続し，4ビットの並列加算回路を
設計する

• 解説項⽬
a. 他プロジェクトからの設計の流⽤

üこれまでの設計回路を新規プロジェクトに追加する
b. バスの利⽤

üこれまでは1ビット信号線のみ，
複数ビット幅を指定できるバスを使う

c. 並列加算回路の構成
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a. 設計の流⽤
• 元プロジェクトからコピって追加する
- 元ファイルとリンクしなくなる
- それで良い時もあるが，元プロジェクトで設計を変更したら︖︖

• プロジェクト作成時の New Project Wizard で追加する
- 元プロジェクトでシンボルファイル .bsf を作成しておく
- “Add Files [page 2 of 5]” にて

ü 必要なファイルが決まっているなら楽
ü 必要なサブファイルも追加する

• Project Navigator ウインドウから追加する
- Files タブ右クリックの “Add/Remove Files in Project...” にて
- Project -> Add/Remove Files in Project... からでもOK

ü とりあえず新規プロジェクト作ってから追加できる
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a. 設計の流⽤
• プロジェクト作成時の New Project Wizard で追加する
- “Add Files [page 2 of 5]” にて
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a. 設計の流⽤
• Project Navigator: Files ウインドウから追加する
- Files 右クリックの “Add/Remove Files in Project...” にて
- Project -> Add/Remove Files in Project... からでもOK
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Filesを選択

右クリック



a. 設計の流⽤
• Symbol ウインドウから既存の .bsf を呼び出せる
- 元プロジェクトのディレクトリから .bsf を開く
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b. バスの利⽤
• 複数ビット幅を持つバスを引く
- 回路図操作アイコンのOrthogonal Bus Tool

ü 太線がバス 細線は1ビットの信号線
- 名前は右クリック ”Properties -> General -> Name” で付ける

ü バス幅は [x..y] で記述する ⼊出⼒端⼦にもバス幅を記述できる
p [x..y]と[y..x]は異なる 特に理由無ければ降順で
p 端⼦名とバス／信号名は必ずしも⼀致させる必要は無い

ü ビットの指定でバス内の⼀部の配線／バスを引き出すことができる
ü 離れた配線／バスに同じ名前を付けると繋がっているとみなされる

p あまり多⽤するとデバッグで苦労するので，効果的に使うこと
ü 信号／バス間を合流させることができる（例︓a[3..1],b[2]）
ü wire で配線名を途中から変更することができる
ü 論理素⼦にもバスを接続できるものがある

p ⼊出⼒でバス幅を揃えることに注意
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b. バスの利⽤

67

⼊⼒端⼦のバス幅

wire素⼦の中継で
バス名を変更

バスの名前と幅

1ビットのみ
引き出す

繋がっている

複数バスの合流

素⼦への
バス接続

1ビットのみ
引き出す

2ビット
引き出す



c. 並列加算回路の設計
• 回路構成
-全加算器を直列に接続する
-加算データは並列に接続される

• 外部仕様
-⼊⼒︓4ビットの加算データA,B
-出⼒︓4ビットの和Sum，1ビットの桁上げCarry
- (せっかくなので)設計制約︓

ü先に設計した全加算器と半加算器を利⽤すること
p 全加算器のみでも構わない

ü⼊⼒，出⼒端⼦ともにバス幅を指定すること
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c. 並列加算回路の設計
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設計してみましょう
Compilation Reportも

確認してみましょう

シミュレーション波形で正しく動いていることも確認しましょう



実習課題(2)︓カウンタの設計

-フリップフロップの利⽤
-3ビット5進カウンタの設計
-クロックとタイミング制約の設定



a. フリップフロップの利⽤
• データを⼀時的に保持できる記憶素⼦
- 順序回路を構成する基本要素
- 基本的にはD-FFを使⽤するのがよい

ü クロック・パルスが⽴ち上がった時に，⼊⼒値Dを取り込み，
次のクロック・パルスで更新されるまでQより出⼒し続ける

ü 実際には，セットアップ時間とホールド時間の間でDの値を⼀定に
保たないと正しい値を保持できない（要はタイミング制約）

ü Qは，CLRNに0を⼊⼒すると0に，PRNに0を⼊⼒すると1に固定される
p CLRNもPRNも負論理
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PRN CLRN CLK D Q
L H x x H
H L x x L
L L x x L
H H ↑ L L
H H ↑ H H
H H L x Qo
H H H x Qo



a. フリップフロップの利⽤
• よくわからない⼈は，⼊出⼒とD-FFのみの簡単な回路 “dfftest” を

設計して，D-FFの動作をシミュレーションで確認してみましょう
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b. 3ビット5進カウンタの設計
• 回路構成
- 同期式順序回路とする

ü ⾮同期式にするとCADツールの
最適化との相性が悪くなることが多い

- クロック信号の⽴ち上がり毎に
値をインクリメントしていく
ü 0 -> 1 -> 2 -> ... -> 4 -> 

0 -> 1 -> 2 -> ...
- リセット信号が0の時は0を出⼒する

• 外部仕様
- ⼊⼒︓1ビットのクロック信号clock

1ビットのリセット信号reset
- 出⼒︓3ビットのカウンタ値count
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Q2 Q1 Q0 D2 D1 D0
0 0 0 0 0 1
0 0 1 0 1 0
0 1 0 0 1 1
0 1 1 1 0 0
1 0 0 0 0 0
1 0 1 x x x
1 1 0 x x x
1 1 1 x x x



b. 3ビット5進カウンタの設計
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c. クロックとタイミング制約の設定
• クロックの指定やタイミング制約（レジスタ⼊⼒へのセットアップ

時間やホールド時間，伝搬遅延など）の設定を⾏う
- 基本的なクロックの指定のみ解説，詳細は各⾃で調査すること．

• TimeQuest Timing Analyzerを使⽤する
- Tools -> TimeQuest Timing Analyzer または，

ツール操作アイコンの “TimeQuest Timing Analyzer”
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c. クロックとタイミング制約の設定
• TimeQuest Timing Analyzer
- Tasks窓の “Netlist Setup -> Create Timing Netlist” を実⾏
- Tasks窓の “Netlist Setup -> Read SDC File” を実⾏
- Constraints -> Create Clock... からクロックを設定
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c. クロックとタイミング制約の設定
• TimeQuest Timing Analyzer
- Constraints -> Create Clock... からクロックを設定

ü Clock name: クロック名の定義（例︓clock，未記⼊でも可）
ü Period: クロック周期の設定
ü Waveform edges: ⽴ち上がり／⽴ち下がり時間の設定
ü Targets: 設計回路上のクロックを選択

p “List”から表⽰して”>”で選択
ü SDC commandに⽣成される

制約が表⽰される
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c. クロックとタイミング制約の設定
• TimeQuest Timing Analyzer
- Reports/ 以下でタイミングに関する種々のレポートが

報告されるようになる
ü 満⾜していないものがあれば制約の追加などで対処する
ü Compilation Report からも確認できるようになる
ü Fmax Summary: 動作可能な最⼤周波数（制約によって変わる）
ü Clocks: 現在設定値での設計回路のクロック周波数

- Tasks窓の “Write SDC File...” で制約ファイルを保存
ü <module>.sdc とするとプロジェクトに⾃動認識される

（.outを取ったほうがよい）
ü ⼿動で追加は Project Navigator ->Files 

から Add/Remove Files in Project...
ü 慣れてきたらテキストベースで

制約ファイルを作成・編集してもよい
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c. クロックとタイミング制約の設定
• 性能の確認（Compilation Reportから）
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他の項⽬の意味は
各⾃で調査する

(レポート作成に有⽤)

タイミング制約下での
最⼤周波数



TIPS
• 回路図エディタについて
- エディタ上のとにかく綺麗な素⼦配置・配線を⼼掛けましょう

スパゲッティ回路図になると，あとで⾃分も(TAも)⼤変です．
- 直線(斜線)の配線もできますが，⾒た⽬がすごく悪くなります．

• インスタンス／バス／端⼦の命名について
- 記号はハイフン ʼ-ʼ とアンダースコア ʼ_ʼ くらいしか使えません．

üハイフンはModelSimでマイナスと認識されてしまいます．
つまり実質的に使えるのはアンダースコアだけです．

- ⼤⽂字と⼩⽂字は区別しません．
- ビット指定は[]を忘れずに．A[2]とA2は異なる信号線になります．
- 数字で始まるモジュール名等はシミュレーションでハマります
- 既存の論理素⼦など⼀般的すぎるもの（いわゆる予約語）は

思わぬバグ混⼊のもとなので，避けたほうがよいでしょう．
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TIPS
• 論理素⼦について
- 基本的にはPrimitivesのみを使ってください．
- 特にDFFのCLRNやPRNなど，負論理であるものがあります．
- 決まった値を⼊⼒したい場合はVCCとGNDが使えます．
- なにも接続していないところは0とみなされる（はずです）
- 各論理素⼦の動作(真理値表)および説明を⾒たい場合は，

Help -> Help Topics 内の検索窓または，
Using HDL with the Quartus Prime Software
-> List of Primitives の下から探してください．
ü Primitivesページのリンクは⾶べないようです
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TIPS
• モジュールについて
- 回路全体ではなく⼀部だけを合成・シミュレーションしたい

場合は，Project Navigator の該当ファイルを右クリックして
”Set as Top-Level Entity” を設定するとよいです．
- シンボルの元の回路図を変更した場合は，シンボルの右クリック

“Update Symbol or Block...” すると変更が反映されます．
• シミュレーション
- modelsim-aseの Transcript サブウィンドウに直接コマンドを

⼊⼒して実⾏できます．
慣れてきたらメニューをクリックするより操作が早いですし，
コマンドヒストリも使えます．
- 実⾏履歴は “./simulation/modelsim/msim_transcript” に残る

ので，編集して別名で保存しておくのもよいです．
Transcriptから do (ファイル名) で実⾏できます．
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TIPS
• 各⾃PCへのQuartus Primeの導⼊
- 機能制限有りの Lite Edition なら無償利⽤可能です

http://dl.altera.com/?edition=lite
- シミュレータはModelSim-Altera Starter Editionを⼊れてください
- 演習室環境と同じStandard Editionだと30⽇間限定になります

来年度実験3のことを考えると導⼊時期は要検討です．
- Pro EditionはFPGAボード搭載のCyclone IVデバイスが対応しません
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TIPS
• エディションの違いについて
- 本演習の運⽤レベルでは⼤きな違いはありません．

ただしLiteだとマルチプロセッササポートがありません．
https://www.altera.co.jp/ja_JP/pdfs/literature/po/ss-quartus-
comparison_j.pdf

• 合成性能・最適化結果がエディションで異なってくる可能性があります
- レポート記載の際には Standard Edition を使⽤するか，

実験環境として使⽤した Edition を明記してください
• バージョン
- Google先⽣に聞く時はツールのバージョンに注意してください．

Quartus Prime 17.1 Std
ModelSim-Altera 10.5b 
- 古い／新しいために，実験環境のバージョンでは通⽤しない

TIPSや解決策に当たることがあります．
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演習課題
• 演習課題1︓ALUの設計
- 配布資料に⽰す外部仕様を満たす

16ビットのALU（算術論理演算器）を設計しなさい．
- 複数の構成⽅式を検討し，それらの⽐較を（少なくとも

定性的に）⽰しなさい．
- 必須機能と発展機能に分かれる．

ü発展機能，複数⽅式の定量的な⽐較評価は，加点要素となる．
• 演習課題2︓任意の順序回路の設計
- 任意の同期式順序回路について仕様を検討し，CADツールを

⽤いて論理設計しなさい．
- ただし，演習課題1のALUを⽤いること．
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演習課題
• レポート内容をまとめた報告書および設計データを提出すること．
- 報告書︓演習課題1と2の報告内容を1つのPDFファイルにまとめること
- 設計データ︓演習課題2のみ プロジェクト全体をzipでまとめること

• 提出⽅法︓PandAの課題提出ページ
• 提出期限︓2020年1⽉28⽇(⽕) 17:00 ※期限厳守︕
- レポートの品質によっては再提出を指⽰することがある．

再提出に該当する場合は 2020年2⽉3⽇(⽉) 17:00 までに連絡する．
- KULASISからの連絡を確認できるようにして，連絡があれば速やかに

応じること．

• 詳細は，配布資料（PandAにも掲載）を参照のこと．
• 配布資料に⽰す注意事項をよく確認すること．
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